//Vào mode previlidge
Router #show run
//xem thông số cấu hình router
Router#configure terminal
//Vào mode cấu hình global
Router(config)#interface dialer 0
//Tạo & cấu hình Interface dialer 0
Router(config-if)#ip address negotiated
//nhận địa chỉ động từ ISP
Router(config-if)#encapsulation ppp
//đóng gói qua giao thức PPP
Router(config-if)#ppp chap hostname (dsl-010101-010)
//nhập username mà ISP cung cấp. Nếu ISP sử dụng phương pháp xác thực là PAP thì dùng command
ppp pap send username (dsl-xxxxx-xx)
Router(config-if)#ppp chap password
//nhập password mà ISP cung cấp . Nếu ISP sử dụng phương pháp xác thực là PAP thì dùng command
ppp pap send password
Router(config-if)#ip nat outside
//khai báo dialer 0 là outside
Router(config-if)#mtu 1492
// xxx
Router(config-if)#dialer pool 1
// Khai báo line ADSL
Router(config-if)#exit
//thoát khỏi cấu hình dialer 0
Router(config)#interface ATM 0
//cấu hình ATM
Router(config-if)#no shutdown
// Enable Internet ATM (Do đây là 1 Interface vật lý nên mọi người lưu ý phải no shutdown Interface này)
Router(config-if)#pvc
//khai báo VPI và VCI mà ISP cung cấp
Router(config-if-atm-vc)#pppoe-client dial-pool-number 1
// ATM sẽ đóng gói packet bằng giao thức PPPoE và sẽ đi ra Internet thong qua dialer pool 1 đã khai báo trên Interface Dialer 0
Router(config-if-atm-vc)#exit
//Thoát khỏi mode config trên Interface ATM0
Router(config-if)#exit
//thoát khỏi cấu hình ATM
Router(config)#interface Ethernet 0
//cấu hình Ethernet 0
Router(config-if)#ip address
//Cấu hình IP LAN cho Interface Ethernet
Router(config-if)#no shutdown
// Enable Internet Enthernet 0
Router(config-if)#ip nat inside
//khai báo Ethernet là inside ( Interface nối trực tiếp với mạng LAN)
Router(config-if)#ip tcp adjust-mss 1452
// xxx
Router(config-if)#exit
//thoát khỏi cấu hình Ethernet 0
Router(config)#access-list 101 permit ip
//tạo bộ access-list để chuẩn bị cho việc port forwarding ( PAT ) các packet trong LAN thành packet WAN hợp lệ
Router(config)#ip nat inside source list 101 interface dialer 0 overload
//Apply việc PAT các gói tin từ LAN ra ngoài WAN
Router(config)#ip router 0.0.0.0 0.0.0.0 dialer 0
// Tạo định tuyến tĩnh cho việc kết nối Internet
Router(config)#ip dhcp pool FPT
//cấu hình DHCP
Router(dhcp-config)#network
//cung cấp pool ip address trong LAN 192.168.1.x /24
Router(dhcp-config)#default-router
//cung cấp default gateway ( IP address của Interface Ethernet )
Router(dhcp-config)#import all
//Chấp nhận thông tin DNS từ ISP cấp về
Router(dhcp-config)#exit
//thoát khỏi cấu hình DHCP
Router(config)#exit
//thoát khỏi cấu hình global
Router#show run
//xem lại thông số cấu hình
Router#show ip interface brief
//hiển thị thông tin về tất cả interface . Kiểm tra Interface Dialer 0 đã nhận được IP WAN từ ISP cấp hay chưa ?
Router#ping IP WAN
Router#show interface dialer 0
No comments:
Post a Comment